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This course has been written for NMR spectroscopists who are 
using the XWIN-NMR software. It will give the reader a basic 
understanding of UNIX, the XWIN-NMR directory structure 
and computer networks. It will also offer help in case of 
trouble. The material is dedicated to XWIN-NMR versions 3.0 
and newer, running on an SGI workstation. Most of it, 
however, is also valid for older versions of XWIN-NMR.

The following conventions will be used throughout the 
manual:

times-italic-bold : UNIX command clicked from the toolchest
courier-bold : UNIX commands entered in a UNIX shell
palatino-italic : XWIN-NMR command clicked from the menu
palatino : XWIN-NMR commands entered on the

command line
courier : any name, e.g. of a user, a host etc.
italic : a file or directory in UNIX
fila : an example of a file in UNIX
dira : an example of a directory in UNIX
dataseta : an example of a dataset in XWIN-NMR 
IRIX >= 6.3 : IRIX 6.3 or newer
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the SGI Toolchest 

The Toolchest is a small window on the desktop of an SGI 
workstation. 

The Toolchest: 

• automatically appears when you log in at a terminal which
is directly connected to the workstation

• offers you a list of system tools and applications
• allows you to start tools and applications by mouse click
• can be customized in your personal file .auxchestrc
• can be started with the command toolchest when you

are logged in over the network

The Toolchest usually contains the following buttons:

Desktop - open a UNIX shell, log out, customize

Selected - handle files and directories graphically

Find - find tools and applications on the local host
- find files, hosts, printers etc. network wide

System - start the system management tools for disks,
 printers, network, system software, users etc.

- restart the window manager, restart the host

Help - the online books and manual pages 
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examples of toolchest functions

Open a UNIX window (a UNIX shell): 
Desktop -> Open Unix Shell

Open a window with icons for several applications:
Find -> Applications

Open the online books for help on various SGI topics:
Help -> Online Books
-> you can also type insight

Install a new user or change an existing user:
System -> System Manager -> Security and Access 
Control -> User manager 1

-> you can also type insight

Log out:
Desktop -> Log Out
-> you can also type endsession [-f]

Shutdown the computer:
System -> System Shutdown
-> you can also type init 0

Reboot the computer:
System -> Restart System

->  you can also type init 6

1.For IRIX <= 6.2: click System -> User Manager
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General system information and setup: 

System -> System Manager

Switch window auto placement on/off:

Desktop -> Customize -> Windows

Enable remote display permanently: IRIX >= 6.3

Desktop -> Customize -> Desktop -> Enable Remote Displ.
-> you can also add xhost + to your .profile 1

Change the UNIX default editor (default is jot):

Desktop -> Customize -> Desktop [-> Utilities] 

-> you can also type desktop in a UNIX shell

Install a new printer:

System -> Printer Manager

-> However, we strongly recommend to use the XWIN-NMR 
command cfpp to install a new printer 2.

Install system software:

System -> Software Manager

-> this command can be used to install SGI software but not 
to install Bruker software

A list of all UNIX commands and their manual pages: 

Help -> Man Pages 

-> each manual page corresponds to the output of the 
command man <command>

1.If you use a csh or tcsh shell then make the entry in the file .cshrc
2.For network printing see the XWIN-NMR online help; click help -> other topics -> network printing
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boot - shutdown - reboot
on SGI

How do you boot an SGI?

If the computer is down and switched on:
• click Restart 

If the computer is switched off: 
• push the power button to switch it on

How do you reboot an SGI?

Do one of the following: 
• click System -> Restart System
• type /etc/reboot
• type init 6

How do you shutdown an SGI?

Do one of the following: 
• click System -> Shut Down System 
• type /etc/shutdown
• type init 0 

shutdown and reboot send a warning to all logged in users 
whereas init 6 and init 0 immediately do a shutdown.

If the system hangs (no mouse/keyboard control), you can 
shutdown the SGI by pushing the power button next to the 
green light1. If this fails, push the power button several times 
or push the small hidden reset button. 

1.The system then tries to properly shutdown as it would do with the command shutdown
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help in UNIX on SGI

Manual Pages: help on UNIX commands

Do one of the following: 
• click Help -> Man Pages or type xman

a list of UNIX commands appears: click on a command 
to get help, e.g. click on find

• type man <command>, e.g. man find

How do I ... : particular tasks 1

Click Help -> How do I... and select a question, e.g.: 
• Find Software and Applications
• Organize Windows
• Setup Connections with Other Workstations

On-line Books: general information

Click Help -> Online Books or type insight
Do one of the following: 

• select a book e.g: SGI EndUser -> Desktop Users
Guide

• search for keywords, e.g.: permissions, desktop,
userid

1.How do I... is available for IRIX >= 6.3
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SGI graphical interface
files and directories displayed as icons

Open a directory and show its contents

1. click Selected -> File QuickFind 1

2. enter the target directory in the text field 
3. double click on the folder icon left of the text field

-> A new directory window opens, showing icons.

Select one or more icons in a directory window 

Do one of the following: 
• click one icon
• press the Shift key and click on several icons
• draw a box around a group of icons

-> All selected icons turn yellow.

Open a file or directory

Double click on the icon.
-> A file is viewed, edited or executed, depending on its 

type. If it is a directory, it is opened.2

Rename a file or directory 

1. click on the icon.
2. type the new name in the white rectangle. 3

Remove a file or directory

1. click on the icon
2. click the right mouse button -> click Remove
1.For IRIX <= 6.2: click Selected -> An icon
2.A file can be an ascii file, an executable program, a tar-file, sub-directory etc.
3.If the name under the icon is not marked by a white rectangle, you have no permission to rename the file.
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Change owner or permissions of a file or directory

1. select the icon 
2. click the right mouse button -> click Permissions

-> a new window opens to change owner/permissions

Move a file to a different directory

1. press and hold down the left mouse button on the icon
2. drag the icon into a different directory window

Copy a file to a different directory

1. press and hold down the Control key
2. press and hold down the left mouse button on the icon
3. drag the icon into a different directory window

Move a group of files to a different directory

1. select a group of icons 
2. press and hold down the left mouse button on one icon
3. drag all selected icons to a different directory window

Place frequently used icons on the desktop

1. open the directory where the icon resides
2. press and hold down the left mouse button on an icon
3. drag the icon onto the desktop 1

Show details of icons, e.g. date, size, file type

Click View -> as List

More information: Help -> Online Books -> SGI EndUser 2
1.You can also drag the icon into the Icon Catalog window (Find -> Icon Catalog)
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basic UNIX commands
on files and directories

◆ pwd
-> print working directory

◆ ls
-> list contents of current directory

◆ cd dira
-> change to directory dira

◆ cp fila filb
-> copy the file fila to filb

◆ mv fila filb
-> move or rename the file fila to filb

◆ cat fila 
-> print the text file fila on the screen

◆ more fila
-> print the file fila page by page on the screen

◆ rm fila
-> remove the file fila

2.For IRIX<= 6.2 click IRIS Essentials, for IRIX>= 6.3 click Desktop User’s Guide
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cd
change directory

◆ cd
-> change to your home directory

◆ cd dira
-> change to directory dira

examples

1.cd /u/data/guest/nmr
-> change to /u/data/guest/nmr

2.cd dataseta
-> change to /u/data/guest/nmr/dataseta

3.cd ..
-> change to /u/data/guest/nmr

4.cd ../../usera/nmr
-> change to /u/data/usera/nmr
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ls
list the contents of a directory

ls
list files and sub-directories in current directory

sdir testbin

ls -l
list complete file information

drwxr-xr-x 3 jim sys 512 Aug 12 07:50 sdir

-rwxrwxrw- 1 jim sys 350 Sep 28 12:52 testbin

group, permissions, owner

ls -al
also list files starting with .

 -rw-r--r-- 1 jim sys 210 Jul 26 14:14 .cshrc

 -rw-r--r-- 1 jim sys 149 Jul 26 16:42 .profile

ls -Rl
also list the contents of all sub-directories

ls -lt or ls -lrt
sort by time of last modification

d =directory

- =file
permissions

no. of links

owner
group

size
date of last mod.

name
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rm
remove files and/or directories

◆ rm fila
-> remove the file fila

◆ rm -r dira
-> remove the directory dira including files and 

subdirectories

◆ rm abc*
-> remove all files beginning with abc 

◆ rm -i abc*
-> remove all files beginning with abc interactively. For 

each file, you are prompted to remove the file or not. 

CAUTION: Files which have been deleted under UNIX can
not be restored!

Some files, e.g. filenames with special characters, can not be 
removed with ’rm filename’. You can, however, try to 
remove them with ’rm -i *’ or with ’rm ./filename’.
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file permissions

The permissions of a file:

• determine what each user can do with the file
• are represented by a set of characters -, r, w and x or by a 

set of numbers between 0 and 7: 

1 = x = executable
2 = w= writable
4 = r = readable

The numbers 3, 5, 6 and 7 are combinations of 1,2 and 4:

e.g. 7 = 4 + 2 + 1= rwx

Each file has 3 sets of permissions for 3 categories of users:

• the actual owner of the file 
• users who have the same group ID as the owner 1

• users who have a different group ID than the owner

Type ls -l filename to see the 3 sets of permissions:

e.g. ls -l fila

 -rwxrw-r-- 1 jim sys 987 Sep 15 15:08 fila

The permissions of the file fila are 764: 

7 = rwx for the owner jim 
6 = rw- for all users of the group sys
4 = r- - for other users

1.The group attribute of a file can be changed with chgrp, the group permissions of a file always refer
to the group ID which is shown with ls -l filename
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chmod
change the permissions of a file or directory

using the character representation

General usage: chmod [ugo][=+-][rwx] filename

examples

After each example the output of ls -l fila is shown.

Make fila read-only for all users:

chmod a=r fila 1

-> -r--r--r-- user group 102 Apr 10 12.20 fila

Add the write permission for all users:
chmod a+w fila
-> -rw-rw-rw- user group 102 Apr 10 12.20 fila

Add the execute permission for user (=owner) and group:
chmod ug+x fila
-> -rwxrwxrw- user group 102 Apr 10 12.20 fila

Take away the write permission for others:
chmod o-w fila
-> -rwxrwxr-- user group 102 Apr 10 12.20 fila

Make the directory tree dira, including all files and sub-
directories, writable for all users:

chmod -R a+w dira

1.For IRIX 5.* chmod +r and chmod a+r set the read perm. for all users, for IRIX 6.* chmod a+r
sets the read perm. for all users, chmod +r sets the read perm. according to umask 
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chmod
set the permissions of a file or directory

using the numerical representation

General usage: chmod xxx filename

examples

After each example the output of ls -l fila is shown.

Make fila read-only for all users:
chmod 444 fila
-> -r--r--r-- user group 102 Apr 10 12.20 fila

Make fila write-only for all users:
chmod 222 fila
-> --w--w--w- user group 102 Apr 10 12.20 fila

Make fila read/write for the owner, read-only for the group:
chmod 640 fila
-> -rw-r----- user group 102 Apr 10 12.20 fila

Make fila read/write/execute for the owner, read/execute for 
the group and execute for others:
chmod 751 fila
-> -rwxr-x--x user group 102 Apr 10 12.20 fila

Make the directory tree dira, including all files and sub-
directories, readable and searchable for all users:

chmod -R 555 dira 1

1.Note that the x-permission (5=rx) means searchable in case of a directory. 
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chown/chgrp
change the owner/group of a file or directory

The usage of chown/chgrp is shown with examples. The 
output of ls -l fila or ls -ld dira shows the result. 

Change the owner of the file fila to usera:
chown usera fila
-> -rw-r--r-- usera system 102 Apr 10 12.20 fila

Change the group of the file fila to grpa:
chgrp grpa fila
-> -rw-r--r-- usera grpa 102 Apr 10 12.20 fila

Change the owner of directory tree dira to grpa:
chown usera dira
-> -rwxr-xr-x usera grpa 512 Apr 10 12.20 dira

Change the owner of directory tree dira, including all files and 
sub-directories, to usera:
chown -R usera dira
-> -rwxr-xr-x usera grpa 512 Apr 10 12.20 dira

Change the owner and group of directory tree dira, including 
all files and sub-directories: 1

touser usera dira
-> -rwxr-xr-x usera grpa 512 Apr 10 12.20 dira

touser is a shell script, delivered with XWIN-NMR. It can, 
for example, be used to change the owner of a dataset:

•  type su - root to become superuser
•  type cd /u/data/usera/nmr
•  type touser userb dataseta
1.The group of dira is set to the group usera belongs to (touser uses chown -R and chgrp -R)
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umask 
set the initial permissions for file creation

The initial permissions of a file are set according to: 
 initial permission = creation permission - umask

The creation permissions are:
666 for files created by an editor (e.g. vi, emacs)
777 for directories and executables created by a compiler 

Each user can set umask in his .profile or .cshrc

The superuser can set umask for all users in the files
/etc/profile and /etc/cshrc 1

We recommend XWIN-NMR users to set umask to 002 or 022

examples

In each example a dataset data1 is created with different values 
of umask. You see the output of ls -ld data1: 2

• umask 000 -> create data1 -> permissions 777
 drwxrwxrwx 1 owner group 10 Jun 7 12:20 data1

-> every user can read and write (process) data1 

• umask 002 -> create data1 -> permissions 775
 drwxrwxr-x 1 owner group 10 Jun 7 12:20 data1

-> only the owner and the group can write data1 

• umask 022 -> create data1 -> permissions 755
 drwxr-xr-x 1 owner group 10 Jun 7 12:20 data1

-> only the owner can write data1

1.Each user can overwrite this value by setting the umask in his personal .profile or .cshrc
2.Note that the permission of all subdirectories and files in data1 are set according to umask
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more UNIX commands 
on files or directories

◆ du [-k] dira
-> disk usage of a directory in number of blocks [Kbytes]

◆ file fila
-> what is the type of the file fila (is it ascii, binary etc.)

◆ mkdir dira
-> create the directory dira

◆ rm -r dira 
-> remove the directory tree dira including all files and sub-

directories

◆ touch fila
-> set the date of the existing file fila or create fila

◆ grep stringa fila
-> search for the string stringa in the file fila

◆ find dira -name fila -print 
-> find the file fila in directory tree dira 

◆ ln [-s] fila filb 1

-> make a [symbolic] link between fila (source) and filb 
(target)

1.Use ln -s when fila and filb reside on different partitions.
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filename substitution

In a UNIX shell, you can use the characters *, ? and [] for 
filename substitution:

* matches any string with zero or more characters 
? matches any single character
[...] matches any one of the enclosed characters

examples

List all files with the suffix .c:
ls *.c

List all files which start with a and have 3 characters:
ls a??

List all files which start with p, q or y:
ls [p,q,y]*

Search for the string zg30 in all files which start with z and 
end with p:
grep zg30 z*p

Search for the string hpdj in all files which start with a, b, c, 
d or e:
grep hpdj [a-e]*
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grep
search for a string in a text file

show the lines containing this string

normal form

Search for string stringa in the file fila:

grep stringa fila

other forms

Search for stringa in all files in the current directory:

grep stringa *

Search in all files which start with a,b,c or d:

grep stringa [a-d]*

Print the lines in fila not containing stringa:

grep -v stringa fila

Ignore upper/lower case in stringa:

grep -i stringa fila

Search for stringa or stringb in the file fila:

egrep -i "stringa|stringb" fila

Search for stringa in the output of ps -ef:

ps -ef | grep stringa 
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find
search for files and directories

in a directory tree

examples

Search for entries (files and directories) called fila in the 
directory tree dira: 
find dira -name fila -print

Search for entries that start with a:
find dira -name "a*" -print

Search for entries not called fila:
find dira ! -name fila -print

Search for entries newer than the file fila: 
find dira -newer fila -print

Search for files bigger than 1000 blocks (512000 bytes) on all 
local partitions, not on NFS mounted partitions:
find / -local -size +1000 -print

Run a UNIX command (e.g. lp or rm) on all entries fila:
find dira -name fila -exec lp {} \;

Delete 2D processed data: 2rr, 2ir, 2ri and 2ii in /u:
1. cd /u/data
2. find . -name "2[ir][ri]" -exec rm {} \;

-> Note that the notation [ir] means i or r.
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install new users

on SGI with IRIX >= 6.3 

1. click System -> System Manager -> Security and 

Access Control -> User Manager -> Add 
2. enter the root password

-> continue by clicking the Next button after each step:
3. enter the new Login Name

4. enter the Full Name

5. click on add a password -> enter the password

6. enter an unused User ID 1

7. accept the default group or specify a different one

8. accept the default home dir. or specify a different one

9. select the IRIX shell of your preference 2

10. click OK to accept the new entry

In step 1, click Edit instead of Add to change an existing user

on SGI with IRIX <= 6.2

Click System -> User Manager -> Add
Enter the same information as described for IRIX >= 6.3. 
The procedure, however, is slightly different: 

• entries are made in one window (no Next button)
• click on open instead of add to change a user entry
• click on other to install a non default shell (e.g. bash)

Important: when computers are in a network, use the
same User ID and Group ID for the same user on each host.

1.Type: cat /etc/passwd to check if a User ID already exists.
2.For the bash, click custom and enter the pathname of the bash, e.g. /bin/bash or /usr/local/bin/bash
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the file /etc/passwd
user account administration

The file /etc/passwd:
• contains the complete login account information
• has one line for each user (account) on the system

Each line contains 7 fields separated by colons:

example

root:a7hIyuhgY4d7i:0:0:Super-User:/:/bin/csh

lp:*:9:9:Print Spooler Owner:/var/spool/lp:/bin/sh

jr::1021:20:J.Red:/usr/people/jr:/usr/local/bin/bash

guest:oLujnWr:998:20:Guest:/usr/people/guest:/bin/sh

meaning of the fields:

1: Login Name 
2: Encrypted password: if empty, the user has no password
3: User ID : must be a unique number for each user 
4: Group Id: must be a unique number for each group 
5: Full Name: the user’s full name, may contain blanks
6: Home directory: usually /usr/people/<user>, but can be different
7: UNIX shell: must contain full pathname e.g. /bin/sh or /bin/bash

The superuser can change the file /etc/passwd in order to: 
• delete a user’s password 
• add a * in the second field for special users like lp, 
demos, 4Dgifts for security reasons 1

• change the UNIX shell (e.g. to bash)

Note that the user jr in this example does not have a 
password. We strongly recommend to give every user a 
password, also the special users (see user lp in the example). 

1.There is no password which translates to the encrypted password *.
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the file /etc/group
group account information

The file /etc/group: 
• contains the complete information for groups of login 

accounts
• has one line for each group on the system

Each line contains 4 fields separated by colons:

example 

root::0:root

user::20:guest,jim

other::995:john,lisa,klp

meaning of the fields:

1: Group Name
2: Encrypted group password: usually empty
3: Group Id: must be unique for a group and the same on each host
4: List of users who belong to this group: separated by commas

Why are users divided into groups?
You can share your files with users within your group and 
protect them from all other users.

The file /etc/group can only be changed by the superuser. 

Important: all users who want to run the XWIN-NMR
automation must be entered in their corresponding group line 
in /etc/group. 1

1.This is NOT done automatically during the installation of a user. 
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UNIX shells

A UNIX shell: 
• is a layer between the operating system and the user. 
• offers the user a way to communicate with the o.s.
• is selected upon installation of a new user

Type echo $SHELL to find out which shell you use!

Different UNIX shells and the files executed during login:

sh (bourne shell) bash csh tcsh

 .profile 1  .cshrc

Important differences between shells 2:

1. how do you set environment variables

sh and bash: 1) variable=value
2) export variable

csh and tcsh: setenv variable value

2. tcsh and bash offer history substitution

you can use the arrow keys to repeat and modify 
previously entered commands. 

The bash is not a standard shell. If it is not installed on your 
computer get it from the Bruker FTP server 3.

1.The bash also executes the file .bashrc if it exists.
2.Type man sh or man csh for more information on these shells.
3.The bash for SGI resides on ftp.bruker.de in the directory /pub/nmr/binarie.indy
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the file .profile

The file .profile: 

• sets your personal UNIX environment
• is executed every time you log in 
• resides in your home directory
• is used in connection with the shells sh and bash

You can edit the file .profile and add your personal
preferences, e.g.: 

umask 002
PATH=$PATH:/usr/local/bin
NMR=/u/data/guest/nmr
export PATH NMR
xw() { xwinnmr; }

Log out and log in again for your changes to take effect: 

• umask will be set to 002
• /usr/local/bin is part of the UNIX search patch 
• you can type: cd $NMR

instead of: cd /u/data/guest/nmr
• you can type xw instead of xwinnmr

Note the difference between NMR, an environment variable and 
xw, a UNIX function.

For csh and tcsh the file .cshrc is used. Note that the setting 
of environment variables is different (see previous page). 
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more UNIX commands
for host and user information

◆ id
-> show the user/group name and ID

◆ uname -a
-> show the computer’s hostname and UNIX version

◆ hostname
-> show the computer’s hostname

◆ who
-> who is logged in and since when

◆ df -k
-> show file system and their available disk space

◆ env
-> show all environment variables 

◆ passwd
-> change your password

◆ sysinfo
-> unique system identification needed for all Bruker 

licenses
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ps
show the UNIX process table

ps -ef

example

ps -ef | grep prog
show all XWIN-NMR processes

kill
terminate a UNIX process

e.g. kill 758 889 792

Use kill -9 PID only if kill PID does not kill the 
process.

UID PID PPID C STIME TTY TIME COMD
root 0 0 0 14:01:12 ? 0:01 sched
root 1 1 0 14:01:12 ? 0:00 /etc/init
root 164 1 0 14:01:48 ? 0:00 /usr/etc/nfsd 4
root 270 1 0 14:01:56 ? 0:00 /sbin/cron
lp 254 1 0 14:01:54 ? 0:00 /usr/lib/lpsched

root 308 1 0 14:01:58 ? 0:00 /usr/diskless/bfsd
demo 312 309 0 14:01:59 pts/2 0:00 /u/prog/cpr/cpr 

UID PID PPID C STIME TTY TIME COMD
demo 758 686 0 17:07:14 pts/1 0:00 /u/prog/cpr/cpr
demo 889 758 0 17:07:24 pts/1 0:00 /u/prog/mod/go
demo 792 758 0 17:07:15 pts/1 0:01 /u/prog/cpr/xcpu
demo 901 811 0 17:09:42 pts/0 0:00 grep prog
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lpstat -t
print the printer/plotter status

Use the command lpstat -t: 

• to see if someone is plotting
• in case of plot/print problems

This is the output of lpstat -t showing:

3 possible problems

scheduler is not running

system default destination: hpdj660c

device for hpdj660c: /dev/plp

hpdj660c accepting requests since Sep 19 15:12

printer hpdj660c disabled since Dec 4 12:28

hpdj660c-9 2726 Dec 4 12:23

the solutions

• start the scheduler: /usr/lib/lpsched
• enable the printer: /usr/bin/enable hpdj660c
• cancel hanging print jobs: cancel hpdj660c-9
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compress, gzip
compression to reduce the size of a file

File compression can be used to: 
• save disk space on rarely used files
• reduce network traffic (for rcp, ftp, E-mail etc.)

Compress a file: fila is replaced by fila.Z:
compress fila

Uncompress a file: fila.Z is replaced by fila:
uncompress fila

Compress a file: fila is replaced by fila.gz:
gzip fila

Uncompress a file: fila.gz is replaced by fila:
gunzip fila

Uncompression does not require the suffix .Z or .gz

The compression factor depends on the file type (20-70%)
gzip gives a better reduction in size than compress. 

If the commands gzip and gunzip are not found, then get 
and install the gzip package from the FTP server 1 

Many files on the Bruker FTP server have the extension .gz, 
which means they have been compressed with gzip.

1.The package gzip for SGI resides in ftp.bruker.de in the directory /pub/nmr/binaries.indy
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partition - file system - directory

/

usr etc
u

data
passwd

people

disk

partition

data blocksi-list
super
block

a partition

corresponds to 

a file system

which can be mounted on 

a directory tree
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partition - file system - directory

A partition is a part of a disk; it contains exactly one file 
system.

A file system is a hierarchical structure on the disk usually 
containing directories and files.

A directory tree is a representation of a file system, it makes 
the file system accessible.

Mounting a file system: installing a connection between a file 
system and a directory tree, which makes the file system 
accessible.

Show mounted file systems and free space: 1

type df -k

This is an example of the output df -k: 

Filesystem Type   kbytes use   avail %use 
/dev/root xfs 930000 755734 174265 81% /

/dev/dsk/dks0d2s7 efs 1030302 790218 240083 77% /v

host_b:/w nfs 1016685 376807 639878 37% /x

Note that the command df -k only shows a file system when 
it is mounted.

1.The command df will show the disk space in blocks, df -k in kbytes.

mounted on 



34
mount
connect a directory tree to a file system

Connect directory /z to the corresponding file system:
mount /dev/dsk/dks0d1s7 /z

Connect directory /z according to the file /etc/fstab:
mount /z

Connect /u on the remote host_a to the local /z:
mount host_a:/u /z
-> not that /u on host_a must be exported

Disconnect directory /z from its file system:
umount /z
-> files are still on disk but not accessible

reasons to unmount a file system

You want to do a file system check, e.g. on /z:

1.umount /z

2. fsck /dev/dsk/dks0d1s7 1 

You want to backup the entire root directory / except the direc-
tory /z (assuming /z is a separate file system):

1.umount /z

2.tar cv /

1.The command fsck can only be used for EFS file systems (type df). XFS file systems can be repaired
with xfs_repair
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archiving with tar

copy to the default tape, usually DAT 

Copy fila (file or directory) from disk to tape:
tar cv fila 

Caution: tar cv destroys the current contents of the tape!

Extract fila from tape to disk:
tar xv fila

List the occurrences of fila on the tape:
tar tv fila

Append fila to the end of the archive:
tar rv fila 
-> Caution: do not exceed the end of the tape 1

Append fila if it does not exist on tape or has been modified:
tar uv fila

Copy the directory-tree dira into the tar-file fila:
tar cvf fila dira

Copy to tape with relative pathnames, e.g.:
cd /u/data/guest/nmr
tar cv dataseta

Copy data with absolute pathnames2, e.g.:
tar cv /u/data/guest/nmr/dataseta

1.On some tape drives the End Of Tape handling does not work correctly and data are destroyed. 
2.In this case dataseta can only be copied back to the same directory; if it does not exist it will be created. 
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how to avoid much typing in UNIX

use environment variables, e.g.: 

 NMR=/u/data/usera/nmr
export NMR
-> these 2 lines can be entered in your file .profile
Type cd $NMR to go to the corresponding directory.

use UNIX functions, e.g.: 

data() { cd /u/data/usera/nmr ;}1

-> this line can be defined in your file .profile
Type data to execute the function.

use cut and paste

• mark text by holding the left mouse button down
• copy this text by clicking the middle mouse button

use the UNIX shells bash or tcsh

• use the arrow keys up/down to repeat and/or modify 
previously entered commands 

• use the Tab key to complete commands 

use a UNIX shell script

They are described on the next pages.

1.The definition of a UNIX function requires two blanks, one after "{" and one before ";".



37
UNIX shell scripts
execute a series of UNIX commands

A shell script:
• is an executable text file
• can contain a series of UNIX commands
• can contain control loops and variables

example

scripta displays the date, current directory + contents:
1. edit a file scripta and enter: 

date

pwd

ls

2. make scripta executable: chmod a+x scripta
3. execute the script by typing ./scripta 1

When executing scripta a possible output is:
Wed Jan 3 03:51:07 PST 1996

/usr/people/guest

scripta

fila

Note: for csh or tcsh, the first line of the script must be:
#! /bin/sh

1."./" means: the command resides in the current directory. You can skip the "./" if the current directory
is part of the UNIX search path. Type echo $PATH to see the UNIX search path.
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UNIX shell scripts 
the use of parameters and control structures

example

scriptb displays the contents of a pulse program:
1. edit the file scriptb and enter: 

dir=/u/exp/stan/nmr/lists/pp

cd $dir

cat $1

$dir = the value of a parameter which is set in the script
$1 = an argument given to the script when it is executed

2. make the file executable: 
 chmod +x scriptb

3. execute the script by typing its name and argument e.g.:
 ./scriptb zg30

Example of a control and loop structure in a shell script: 1

for i in ‘ls *.c‘  

do 

if grep strn $i  

then

rm $i  

fi

done

1.For more information on control and loop structures type man sh or man test.

for all files with the 
extension .c

if the file contains
the string strn

remove the file
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cron - crontab
execute a command daily, weekly

Any UNIX command or program can be executed automati-
cally on a regular basis.

1. check if cron is running: ps -ef | grep cron
if cron is not running: sh /etc/init.d/cron start 

2. create a crontab file using the following syntax: 
min hour daymo month daywk command

min: minute (0-59)
hour: hour (0-23)
daymo: day of the month (1-31)
month:  month of the year (1-12)
daywk: day of the week (0-6 with 0=Sunday)
command: the command or program to be executed

Suppose you want to: 

• backup your data at 4.30 am on Tuesday to Friday
• delete all core files at 2 am on Sunday

Note that the second task needs superuser permissions. 

a) type cd to go to your home directory

b) type su to become superuser

c) edit the file fila and enter the following lines:
30 04 * * 2-5 tar cv /u/data/<user>/nmr

00 02 * * 0 find / -name core -exec rm {} \;

d) type crontab fila

You can skip step b) if all tasks in your crontab file can be done 
as normal user. Type man crontab for more information. 
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function keys in X-windows
set function keys for a winterm

1. type cd to change to your home directory 

2. edit a file named wkeys

enter your personal function keys e.g.:

F1(shift): send("lpstat -t")

F1(control): send("ps -fulp")

F1(): send("ps -ef | grep prog")

F2(shift): send("cd ‘curd -a‘")

F2(control): send("ftp ftp.bruker.de")

F2(): send("ftp ftp.bruker.com")

3. edit the file .auxchestrc;

enter the following line:

Menu Desktop

{

"Wkey" f.exec "xwsh -name winterm -key wkeys"

}

4. log out and log in again

5. click on Desktop -> Wkey, which will open a new winterm 
in which you can use the function keys

Each key can be used for three different commands by using 
the Shift and Control modifiers. Note that the order of the 
lines is important: key(shift), key(control), key().

Type man winterm for more information on winterm. 



41
troubleshooting UNIX
things you can do if you have problems

on UNIX or XWIN-NMR level

1. always check the available disk space:

a) type df

b) if the partition / is full:

• find / -name core -exec rm {} \;
• cd /usr/adm/crash 
• rm *unix* *core*

c) if another partition, e.g. /x, is full:

• find /x -name core -exec rm {} \;
• remove processed data in XWIN-NMR with delp
• back up raw data and then remove them with dela

2. shutdown and switch off the computer: 

a) shutdown the computer; type /etc/shutdown

b) switch the computer off 

c) switch the computer on, it will boot automatically

3. log in as a different user; if there are no problems now:

a) save the files in your home directory on a tape

b) delete the user including the home directory

c) re-install the user 

d) copy those files you really need back from tape to your 
home directory
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4. If you run IRIX <= 6.2 and see one of the following effects: 

• several Toolchest -> System functions do not work
• the icons for the tape, CD, camera, etc, do not appear
then the object server probably does not run:

a) open a UNIX shell

b) become superuser; type su

c)chkconfig objectserver on

d)/etc/init.d/cadmin stop

e)/etc/init.d/cadmin clean

f)/etc/init.d/cadmin start

g)/etc/reboot

5. If the screen is frozen: 
a) press the Esc key

b) press 5 keys Shift-Ctrl-Alt-F12-/ simultaneously
where / is the key left of the Num Lock key 1

-> this will force a log out 
c) if the system is connected to the network, log in as root 

via another computer and type /etc/reboot

d) push the power button

-> this will do a proper shutdown
e) push the small hidden reset button 

-> this will briefly cut off the power

Caution: if you reboot or shutdown the system, first check 
who is logged in, type who

1.This is the / in the numeric pad on the right side of the key board. 
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Part II

XWIN-NMR

help

directory tree
AU programs

customizing

troubleshooting
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help in XWIN-NMR
The complete XWIN-NMR manual and many other documents 
(e.g. this manual) are available as online help. 

click on the Help menu

Click on the XWIN-NMR menu item Help. The entries 
Contents and Index are organized in hypertext. You can select 
an item and the corresponding page will be displayed 
automatically. 

Help on any XWIN-NMR acquisition command:
Help -> Acquisition Reference Manual

Help on any XWIN-NMR processing command:
Help -> Processing Reference Manual

The XWIN-NMR Release letters:
Help -> Release Letter

This manual: 
Help -> Other topics -> XWIN-NMR and Unix

The programs XWIN-PLOT and ICON-NMR open separate 
windows with their own Help menus. 

Frequently Asked Questions on WWW

Start you web browser and enter the following url :
http://www.bruker.de 

click NMR -> Software -> FAQ 
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enter xhelp on the command line

All XWIN-NMR help files reside in the directory: 

/<xwhome>/prog/docu/english/xwinproc 1

All files can be displayed by entering xhelp pathname, 
where pathname is the relative path of the help file, e.g.:

• an XWIN-NMR help file: 
xhelp xwinproc/pdf/tutor1d.pdf 

• an ICON-NMR help file: 
xhelp iconman/pdf/routine.pdf

• an XWIN-PLOT help file:
xhelp xwpman/pdf/xwp.pdf

• an arbitrary pdf file : 
xhelp /usr/people/guest/myfile.pdf 

If you often use certain help documents, you can set up a 
macro with edmac and enter the line: xhelp pathname

start help from a UNIX shell 

If XWIN-NMR does not run you can still use its online help: 
1. open a UNIX shell 

2. cd /usr/adobe/Acrobat?.?/bin

3. ./acroread

• click on File -> Open
• enter the pathname in the Selection field, e.g.: 

/<xwhome>/prog/docu/english/xwinproc/pdf

1.<xwhome> is the directory in which XWIN-NMR is installed.
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XWIN-NMR directory tree

<xwhome> - the directory where XWIN-NMR is installed
 default directory: /u

conf - spectrometer configuration files
- printer/plotter configuration
- service tools for bsms, acb, hppr, rx22 etc.

guide - NMR-GUIDE installation directory
exp - parameter sets, pulse programs, AU programs,

several lists
prog  - XWIN-NMR modules and graphics program

 - online documentation
 - Bruker library AU programs 
 - Bruker UNIX scripts

perl  - perl interpreter for interpreting Perl scripts
gnu  - GNU C-compiler for compiling AU programs
print - programs for laser printers
plot - XWIN-NMR plot programs

conf

exp

plot

prog perl

print

<xwhome>

guide

gnu
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directory conf/instr
spectrometer configuration

XWIN-NMR commands and the files they access
uxnmr.info, uxnmr.conf, uxnmr.par, nuclei, ednuc, prosol, param, tunefile,solvloop, eduser, scon, edscon, 

rs232_device, bsms, scm, bacs, temp, cfbsms, cfscm, cfbacs, cfte, edlock, 2Hlock, curinst

<instr> is the instrument name entered during cf
Type cat /<xwhome>/conf/instr/curinst to view the 
instrument name

rs232_device prosol
cortab

2Hlock

bsms
scm
bacs
temp

cfbsms
cfscm
cfbacs

cfte

edlock

cortab

edprosol

<xwhome>

conf

instr

<instr>

<headid>

param
tunefile

scon

edscon

uxnmr.par

curinst

nuclei

uxnmr.info

ednuc

cf
probehead

<solvent>

patchlev

edhead
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directory exp/stan/nmr
XWIN-NMR experiment files

directories containing XWIN-NMR experiment files
par.300, par, form, lists, lut, au, standard parameter sets, format files, pulse programs, au programs

The exp directory contains both Bruker standard and your
own pulse programs, AU programs and parameter sets. 

Keep a backup of this directory!

<xwhome>

exp

nmr

stan

au

lut

lists form

par.avance

AU

2D lookup
tables

several
lists,
pulse

programs

format
files

installed
parameter

sets

standard
parameter

sets for programs

par

HR-Avance
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directory exp/stan/nmr/lists

directories containing lists for acquisition

pp: pulse programs used by edpul, edcpul, zg etc.
cpd: cpd decoupling programs 
scl: scaling region files for PSCAL=sreg or psreg
gp: gradient programs
wave: shape pulses
group: example and user defined tune files
mac: macros accessed by edmac and xmac
intrng: integral ranges accessed by rmisc, wmisc
bsms: shim files accessed by rsh, wsh, vish
f1, vd: frequency and delay lists accessed

by zg if used in the pulse program

<xwhome>

exp

stan

nmr

lists
pp

intrng

cpd
bsms

f1

vd

mac

scl

probeheads

edhead

gp
wave group
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directory exp/stan/nmr/lists/pp
XWIN-NMR pulse programs

directories containing pulse programs

pp.dsolids, DSX, pp.dexam, DMX, DRX, DPX, pp, AMX, pp.exam, ARX, pp.rexam, ASX, pp.solids, lists

The directory pp contains the pulse programs which are used 
in XWIN-NMR by edcpul, as, zg etc.

The directories pp.xxxx contain Bruker standard pulse pro-
grams for the various spectrometer types.

The command expinstall copies pulse programs from 
pp.xxxx (depending on the spectrometer type) to pp.

The directory pp also contains all user defined pulse programs.

pp.solids

ASX

<xwhome>

exp

stan

nmr

lists

pp.dexam

pp.dsolids

pp.exam

pp.rexam

pp

ARX

AMX

Avance-AQX
Avance-AQS

DSX
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directory exp/stan/nmr/form
format files 

XWIN-NMR commands and the files they access
 proc.e, edp, outd.e, edo, prosol.e, prosol, normpl, plot, plotx, normlp, lpa, lpp, lpg, normdp, dpa, dpp, dpg, edsp, 
edasp, spec.e, edc, curd.e, eda, acqu.e, form

Format files determine the format of a parameter list:
• they can be changed by the NMR Superuser only
• you can add/remove parameters or change comments
• never change relations between parameters! 

<dir>.l

normlp

lpa
lpp
lpg
..

proc.e

outd.e

normplnormdp

dosy.e

curd.e

acqu.e
edp

edo

eddosy

edc

eda

dpa
dpp
dpg

..

plot
plotx

..

<xwhome>

exp

stan

nmr

form

scon.e

edscon
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normpl - normplot
which parameters appear on the plot?

XWIN-NMR commands and the files they access

proc.1, plot, edo, acqu.l

The format file normpl contains only a subset of the 
parameters, normplot contains all parameters.

Only the parameters in normpl will appear on the plot.

The NMR Superuser can edit normpl and add parameters con-
tained in normplot, e.g. the processing parameter TDeff or the 
acquisition parameter TE.

<xwhome>

exp

stan

nmr

form

acqu.l proc.l

normplot normpl normpl normplot

TE TDeff

acquisition processing

plot
edo
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directory prog
XWIN-NMR programs / executables

installnmr, shmrm, , pstruc_all.h, aucmd.h showconf rstest install.net

docu: online documentation (in PDF format)

curdir/<user>: XWIN-NMR user specific files, e.g. history

bin: XWIN-NMR binaries and UNIX shell scripts

bin/install.net: spectrometer network installation files

app-defaults: resources (e.g. colours) for XWIN-NMR 1

include: h-files and command table for AU programs

include/inc: macros for AU programs

mod: modules; XWIN-NMR’s main executables

1.Ascii files, also for XWIN-PLOT, PARAVISION etc., which can be modified by the NMR Superuser.

xwinnmr
shmrm

installnmr
showconf
rstest

prog
docu

 includecurdir
app-defaults

mod

bin

install.net

manual.63
manual.65

aucmd.h

history
inc

<xwhome>

<user>

pstruc_all.h
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Bruker programs executed in UNIX

The following scripts reside in <xwhome>/prog/bin. Normally, 
you can start them in any directory. If, however, they are not 
found enter the full pathname, e.g. /u/prog/bin/shmrm.

◆ installnmr 1

-> install current version, set XWIN-NMR permissions etc.

◆ shmrm
-> remove all shared memories 

◆ touser 
-> set the owner and group of a directory (e.g. a dataset)

◆ uxproc
-> shows all running or hanging XWIN-NMR processes

◆ patchlevel 
-> show the current XWIN-NMR patchlevel 

◆ curd 
->  current XWIN-NMR dataset (usage: cd ‘curd‘)

◆ reviveccu
-> reset the spectrometer CCU

◆ showconf
-> print the configuration of the workstation and the 

spectrometer into a file (including cf, hinv etc.) 

1.installnmr is automatically executed during the installation of XWIN-NMR.
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directory data
a 1D dataset

acquisition parameters, acqu, acqus, meta, plot parameters, proc, procs, processing parameters, integral ranges, 
intrng, peak records, peaks, raw data

The data files fid, 1r, 1i are binary files containing integer 
numbers (the intensities of the data points).
All parameter files are ascii files in JCAMP format.
<xwhome> can be any directory e.g. /u or /usr/people/guest 
and is independent of the XWIN-NMR installation path. 

ranges

<xwhome>

data

<user>

nmr

<name>

1

pdata

1

procintrng

fid

outd

1r

acqu

meta

processing
parameters

plot
parameters

real and imaginary
part of the processed data

integral

printer +
xwp layout

procs1i

acqus

raw
data

acquisition 
parameters

pulseprogam

preprocessed
pulse program
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directory data
acquisition, processing and status parameters

1r, 1i, meta, edg, dpg,fid

The acquisition parameters in acqu are set with eda.

The processing parameters in proc are set with edp.

The status parameters in acqus (procs) can be viewed with dpa 
(dpp) after acquisition (processing).

pdata

1

meta

edg
dpg

<xwhome>

data

<user>

nmr

<name>

1

procsproc

acqu acqus

fid dpaeda

edp dpp

1r
1i
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directory data
2D dataset

acquisition parameters, acqu, acqu2, acqus, acqu2s, proc, proc2, procs, proc2s, processing parameters, 2rr, 2ir, 2ri, 
2ii, dsp, processed data, meta, plot parameters, p2r1, p2r2, n2r2, n2r1, projections, contour levels, level, luta, 
colour lookup table, title, plot title, ser, raw data

The files ser, 2*, dsp and dsplow are binary files containing 
integer numbers (the intensities of the data points). 

All parameter files and the file title are ascii (JCAMP). 

The file level is binary.

data

<user>

nmr

<name>

1

pdata

<xwhome>

acqu
acqu2
acqus
acqu2s

1

proc
proc2
procs
proc2s

p2r1
p2r2
n2r2
n2r1

2rr
2ir
2ri
2ii

ser

title

outd

level processing
parameters

acquisition
 parametersraw

data

plot
title

printer +
xwinplot

layout

contour
levels

projections processed data

meta

plot 
parameters

dsp
dsp_low
dsp.hdr

compressed 
data for display
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2D dataset
troubleshooting 

Sometimes a 2D dataset cannot be displayed in XWIN-NMR; 
when you try to read the data a graphics restart occurs.

example

Reading the dataset /u/data/usera/nmr/dataseta fails. 
Do the following to solve the problem:

1. open a UNIX window

2. go to the processed data directory: 
 cd /u/data/usera/nmr/dataseta/1/pdata/1

3. after each step try to read the data in XWIN-NMR:
• rm dsp* - no information will be lost, XWIN-NMR

will automatically create new dsp files

• rm level - you loose your contour levels
- XWIN-NMR will create a default level file 
- change the default levels with edlev

• rm 2* - you loose the processed data
- re-process the data with xfb 

• cp /<xwhome>/exp/stan/nmr/par/standard2D/meta ./

- or copy any other 2D meta file 
- you loose the plot parameters 
- re-define the plot parameters with edg



61
rmisc/wmisc
read/write a dataset specific list

XWIN-NMR commands and the files they access 1

1i, 1r vd, vdlist1, intrng

Note the difference between edmisc and edlist: 
• edmisc edits lists specific for one dataset; these lists 

concern data processing and analysis
• edlist edits lists available for all datasets, these lists 

mainly concern data acquisition

1.the misc commands also handle the files reg, peaklist, base_info and baslpnts

<xwhome>

exp

stan

nmr

lists

intrng

my_intrng

<xwhome>

data

<user>

nmr

<name>

1

pdata

1

1r 1iintrng

wmisc

rmisc

vd

vdlist1

edmisc

edlist
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rmisc/wmisc
read/write a dataset specific list

example

1. read a dataset, e.g. dataseta 1 1 /u usera, enter the integrate 
menu and determine the integrals. 

2. click File -> Save as ’intrng’
this stores the integral ranges in the file: 
/u/data/usera/nmr/dataseta/1/pdata/1/intrng

3. type wmisc intrng my_intrng
this copies the file: 
/u/data/usera/nmr/dataseta/1/pdata/1/intrng

to the file:  
/<xwhome>/exp/stan/nmr/lists/intrng/my_intrng

4. change the dataset, e.g. to: datasetb 1 1 /u usera

5. type rmisc intrng my_intrng
this copies the file:
/<xwhome>/exp/stan/nmr/lists/intrng/my_intrng

to the file:
/u/data/usera/nmr/datasetb/1/pdata/1/intrng

6. enter the integrate menu and click File -> Read ’intrng’

7. click on lastscal to see the integral labels in AI 
 (absolute intensity) mode. 

The commands rmisc, wmisc and edmisc apply to the 
following data set specific lists in XWIN-NMR: intrng, 
baslpnts base_info, peaklist and reg.
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rpar - wpar
read - write parameter sets 

XWIN-NMR commands and the files they access
acqu, par.300, proc

The command rpar reads a parameter set into the current data 
directory. The command wpar stores a parameter set of the 
current dataset for general usage. The command expinstall 
converts Bruker standard parameter sets to the frequency of 
your spectrometer. 

<xwhome>

data

<user>

nmr

<name>

1

pdata

1

proc
meta

meta.ext
outd

<xwhome>

exp

stan

nmr

par par.avance

PROTON

acqu
proc
meta

meta.ext
outd

acqu
proc
meta

meta.ext
outd

acqu

PROTONwpar

rpar

wpar

rpar expinstall



64
AU programs in XWIN-NMR

XWIN-NMR commands and the directories they access
include, pstruc_all.h, aucmd.h, edau, edaumod, expinstall, au

src.exam: Bruker standard AU programs

src: installed Bruker and User AU programs

bin: executables of Bruker and User AU programs

inc: macros that can be included in AUprograms

For more information on writing and using AU programs click 
Help -> Other Topics -> Writing AU programs

aucmd.h

pstruc_all.h

<xwhome>

prog

au

<xwhome>

exp

stan

nmr

au

src.exam

bin

include

expinstall

edau

src

inc
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The command expinstall copies all Bruker AU programs
from: /<xwhome>/prog/au/src.exam 
to: /<xwhome>/exp/stan/nmr/au/src

You can also use the command edau 5 to do this. 

After running expinstall, you can use 3 different commands to 
compile AU programs: 

compileall: compile all AU programs 
cplbruk [<name> | all ] : compile Bruker AU programs 
cpluser [<name> | all ] : compile user AU programs 

The command edau [<name>] allows you to:
• create a user AU program which will be stored in: 

/<xwhome>/exp/stan/nmr/au/src
• edit a user AU program or view a Bruker AU program in: 

/<xwhome>/exp/stan/nmr/au/src
• compile an AU program and store the executable in: 

/<xwhome>/prog/au/bin 

The command xau [<name>] compiles an AU program 1 
(if necessary) and executes it.

commands and parameters

The ascii file /<xwhome>/prog/include/aucmd.h shows: 

• which XWIN-NMR commands can be used in AU program
• their syntax, e.g. the number of arguments

The ascii file /<xwhome>/prog/include/pstruc_all.h contains a 
list of acquisition and processing parameters 2 and can be used 
to view the type of a parameter (int, float, double etc.)

1.xau also compiles all AU programs which are called within an AU program.
2.The file pstruc_plot.h contains a list of plot parameters. 
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macros in XWIN-NMR
execute a series of XWIN-NMR commands

A macro, like an AU program, can execute a series of XWIN-
NMR commands. 

Differences between macros and AU programs:

• a macro always starts on the foreground dataset 1

• a macro does not need to be compiled
• a macro cannot execute C language statements

You can create or change a macro by typing edmac <name>

example

1. type edmac my_mac to create/change the macro and 
enter your macro commands e.g.: 

ef

apk

sref

abs

autoplot

store the macro and leave the editor
2. execute the macro by typing my_mac or xmac my_mac

All macros are stored in the directory: 

/<xwhome>/exp/stan/nmr/lists/mac

1.If you change data sets in a macro, the foreground data set also changes.
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setres
the XWIN-NMR user interface 

1. start xwinnmr
2. type setres 1

Select the XWIN-NMR layout (standard, extended, uxnmr)
• standard is the default XWIN-NMR layout
• the extended layout contains additional buttons 
• uxnmr is the layout of the traditional UXNMR program

Select data field colours e.g. for spectrum, axis etc. 2

’double click’ on the colour names to select a colour

Set XWIN-NMR environment variables: 
• Editor: set the XWIN-NMR editor (e.g. vi, xedit, jot) 
• Exploc: if set to "xxx", the directory /<xwhome>/exp/xxx 

is used instead of /<xwhome>/exp/stan 
• Plotter: printer/plotter used by XWIN-NMR; the entry 

CURPLOT in edo is ignored from now on 
• PlotMsg: switch on/off the plot message after plot 
• ZGsafety: switch on/off the warning from the zg 

command that an existing FID will be overwritten

Switch on/off the history function
The file /<xwhome>/prog/curdir/<user>/history contains 
all executed commands and error messages of the current 
XWIN-NMR session. 3

1.setres information is stored in /usr/people/<user>/.xwinnmr-<hostname>/resources.
2.Additional colours can be set in /<xwhome>/prog/app-defaults/XWinNmr or your personal .Xresources
3.The history file is emptied when you exit and restart XWIN-NMR.
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XWIN-NMR resources
colours and function keys 

user specific resources

You can define your personal XWIN-NMR function keys: 
1. log in as normal user
2. edit the file /usr/people/<user>/.Xresources 

enter your personal XWIN-NMR function keys e.g.:

XWinNmr*cmdline*translations: #override \n\

Ctrl<Key>F2:insert-string("edo") \n\

Shift<Key>F2: insert-string("edp") \n\

<Key>F2: insert-string("eda") \n\

Ctrl<Key>F3: insert-string("xwinplot")

3. log out and in again
If you add the string process-return(), e.g.:
<Key>F2: insert-string("eda") process-return() \n\

the command is immediately executed. 1

The keys F1 and F10 cannot be used for XWIN-NMR. All other 
keys can be used for 3 different commands, e.g.: 

type Control-F2 to start edo
type Shift-F2 to start edp
type F2 to start eda

Important: if you put 3 functions on one key, the order in the 
file .Xresources must be Ctrl<Key> - Shift<Key> - <Key> 
No blanks or tabs are allowed at the end of the line. 

1.If you add the string beginning-of-line() kill-to-end-of-line() before the string
insert-string("") any characters which already exist on the command line will be removed. 
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You can define your personal XWIN-NMR menu colours: 
• log in as normal user
• edit the file /usr/people/<user>/.Xresources 

enter your personal XWIN-NMR menu colours e.g: 

XWinNmr*foreground:darkseagreen

XWinNmr*background: maroon4

XWinNmr*XmText.background: aquamarine

XWinNmr*XmTextField.background: cadet blue

• log out and log in again

The colours for XWIN-NMR data field objects (spectrum, axis, 
background etc.) can only be set with the command setres 1. 

You can view a list of available colours with the command 
colorview in a UNIX shell or with setres in XWIN-NMR.

resources for all users

XWIN-NMR resources can also be defined for all users:
1. log in as root
2. edit the file /<xwhome>/prog/app-defaults/XWinNmr 
3. enter function key or colour definitions

The format of the file XWIN-NMR is the same as for the file 
.Xresources (see examples above).

The directory /<xwhome>/prog/app-defaults contains separate 
resource files for the different software components like 
xwinplot, view and pulsedisplay.

1.Double click on the colour name in setres to see the colour.
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cpan
the XWIN-NMR command panel

The XWIN-NMR command panel cpan allows you to: 
• setup a user defined window with XWIN-NMR commands
• give XWIN-NMR commands different names (aliases) 
• add short explanations to the commands

How do you set up a command panel?
• type cd to go to your home directory
• type mkdir -p .xwinnmr-xyz/cmdpanels 1

 where xyz is the hostname of your host
• type cd .xwinnmr-xyz/cmdpanels
• edit a file named default 2 and enter for example:

TITLE
1D Processing  title of the cpan window 
BUTTON
NEWROW  position of the button
ft  XWIN-NMR command
fourier  alias name for command
1D Fourier Transform  short explanation
BUTTON
SAMEROW position of the button
etc. further entries

END

- Note that TITLE, BUTTON etc. are fixed keywords. 

Now start XWIN-NMR and enter the command cpan 3

1.You have to do this step only once. 
2.default is the cpan startup file; you can setup additional files and use the load button in the cpan window
3. expinstall -> "Install Bruker Library AU Programs" must have been executed once before using cpan
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troubleshooting XWIN-NMR 
hang-ups and crashes

1. if an XWIN-NMR command has hung up:

 type kill to kill possibly hanging processes

2. if no keyboard or mouse control in XWIN-NMR

a) move the cursor into the UNIX shell where XWIN-NMR 
was started

b) type ^\ (control backslash)

c) answer the question for restart with "no"

d) type shmrm

e) type uxproc

f) kill any hanging XWIN-NMR processes with:

kill PID 1 (if this does not work, try kill -9 PID)
g) type xwinnmr to restart XWIN-NMR

3. if no keyboard/mouse control on the entire screen

a) if the computer is on the network, log in from another 
terminal

b) perform step ’e’ to ’g’ as described under ’2’

c) if this does not help, reboot the computer from the remote 
terminal: type: /etc/reboot

d) if the computer is not on the network, push the power 
button or, if necessary, the hidden reset button

For more troubleshooting information click Help - Installation 
Guide

1.PID is the first number in the output of uxproc
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troubleshooting printing

1. check the plot status in UNIX

a) type lpstat -t

• is a previous plot hanging?
• is the printer enabled?
• is the scheduler running? 

b) solve possible problems as described on page 29

2. switch the printer off and on again

3. only one UNIX processes lpsched should run 

a) type ps -ef | grep lpsched

b) if 2 or more processes lpsched are running:

• type: /usr/lib/lpshut
• type ps -ef | grep lpsched
• kill remaining lpsched processes: type kill PID 1

• type /usr/lib/lpsched to restart the scheduler
• check with lpstat -t if the scheduler is running 

4. check if the printer cable is properly connected

5. remove and re-install the printer 

a)  in XWIN-NMR

• type cfpp
• click printer-plotter installation
• click remove printer-plotter

1.Try kill -9 if kill does not work. 
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b) if the printer cannot be removed in XWIN-NMR, try in

UNIX
• type /usr/lib/lpshut
• type /usr/lib/lpadmin -xprintername

(printername is, for instance, hplj4l)
• type /usr/lib/lpsched

c) now re-install the printer in XWIN-NMR

• type cfpp
• click printer-plotter installation
• click install new printer-plotter

6. If the scheduler cannot be started with

/usr/lib/lpsched, even after step 3, then reboot the 
computer; type /etc/reboot

7. Check if the RS-232 port is inaccessible

a) connect the printer to another port

b) switch the printer off and on again

c) in XWIN-NMR:

type cfpp
click printer-plotter installation
click change output device of existing printer-plotter



74
Part III

NETWORKS

network communication

ftp transfer 

spectrometer network
internet

www
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network communication
network commands 

host_a: the computer on which you are logged in 
host_b: a remote computer in the network

◆ telnet host_b
-> log in on host_b, you will be asked for a login name

◆ rlogin host_b
-> log in on host_b as current user

◆ rcp fila host_b:/u
-> copy fila from host_a to host_b into directory /u

◆ rcp host_b:/usr/people/guest/fila /u
-> copy fila from host_b to host_a into /u

◆ rcp -r dira host_b:/u/data/guest/nmr
-> copy the directory tree dira from host_a to host_b

◆ rsh host_b who
-> run the command who on the remote host host_b

◆ cat fila | rsh host_b lp
-> print fila on a printer connected to remote host host_b

Note that for rlogin, rcp and rsh the remote host must be 
entered in the file /etc/hosts.equiv or your personal .rhosts file.
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network communication
remote login and remote copy with FTP

Differences between ftp and rcp: 
• ftp requires a login with password on the remote host
• ftp does not check /etc/hosts.equiv or .rhosts
• ftp cannot directly transfer directory trees

examples

1. the file fila in /usr/people/demo on host_b is copied to 
/usr/people/guest on host_a: 

a) log in on host_a as user guest 

b) type ftp host_b
Name: guest  --> enter a user name
Password:   --> enter the password 
ftp> lcd /usr/people/guest--> change local directory (host_a)
ftp> cd /usr/people/demo  --> change remote directory (host_b)
ftp> bin  --> switch to binary mode
ftp> get fila  --> get fila from host_b to host_a
ftp> bye  --> leave FTP

2. the file filb in /usr/people/guest on host_a is copied to
/tmp on host_b:

a) log in on host_a as user guest

b) type ftp host_b
Name: guest  --> enter a user name
Password:  --> enter the password 
ftp> lcd /usr/people/guest--> change local directory (host_a)
ftp> cd /tmp  --> change remote directory (host_b)
ftp> bin  --> switch to binary mode
ftp> put filb -  --> put filb from host_a to host_b 
ftp> bye  --> leave FTP
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commands in FTP

pwd print remote current directory

dir, ls list contents of remote current directory 

cd change directory on the remote host 

lcd change directory on the local host

bin switch to binary mode

get fila copy the file fila from the remote host

put filb copy the file filb to the remote host

prompt mget and mput copy all files without asking 

hash print a # for each buffer transferred

mget a* copy all files a* from the remote host

mput a* copy all files a* to the remote host 

reget continue an interrupted transfer of a file 

help show all FTP commands

help cmd help for a specific command

bye leave FTP

Important:

• executable files loose their x-bit during FTP transfer: leave 
FTP and use chmod a+x filename to set the x-bit

• binary files must be transferred in binary mode otherwise 
they will be corrupted. (ascii files can be transferred in 
binary and ascii mode)
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copy directory trees with FTP

FTP cannot directly transfer directories. You can however copy 
a directory into a tar-file and transfer this tar-file with FTP. 

Suppose the user guest: 
• is already logged in on host_a
• wants to get the dataset /u/data/guest/nmr/fila from

host_b and copy it to /z/data/guest/nmr on host_a

1. telnet host_b
-> login on host_b, e.g. also as guest

2. cd /u/data/guest/nmr
-> change directory on host_b

3.tar cvf fila.tar fila
-> copy the dataset fila into the tar-file fila.tar 

4. ftp host_a
Name: guest --> enter a user name
Password:  --> enter the password of guest

ftp> cd /z/data/guest/nmr --> go to the target directory
ftp> bin --> switch to binary mode
ftp> put fila.tar --> put the tar-file on host_a
ftp> bye --> leave FTP

5.rm fila.tar
-> remove the tar-file on host_b

6. exit 
-> go back to host_a

7. cd /z/data/guest/nmr
-> change to target directory on host _a

8. tar xvf fila.tar
-> unpack the tar-file on host_a

9.rm fila.tar
-> remove the tar-file on host_a
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World Wide Web
the internet information service

Bruker offers a large amount of information about hardware, 
software, applications, employees etc. on the WWW. 

Homepage Bruker Germany: http://www.bruker.de

From this page you can: 
• get a Bruker WWW account: 

-> click Register Now, fill out the form, click Submit

•check the list of Frequently Asked Questions:
-> click NMR -> FAQ

• check the list of known bugs or send a bug report: 
-> click NMR -> Known Bugs

• read documentation directly from the web: 
-> click Downloads -> Documentation 

• download patches from the web: 
-> click Downloads -> Update&Patches 
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the Bruker FTP server

The Bruker FTP server contains:
• patches for XWIN-NMR releases
• Bruker software packages e.g. Aurelia, Xwinplot
• general software packages e.g. gzip, perl, emacs
• the /incoming directory to send data or files to Bruker

How do you access the FTP server?
• log in on a computer that is connected to the internet
• type ftp ftp.bruker.de (Germany)

or ftp ftp.bruker.com (USA)
• log in as anonymous or ftp 
• enter your own full E-mail address as password

The most important directory on ftp.bruker.de for NMR users 
is /pub/nmr. An exact copy of this directory is available on 
ftp.bruker.com as /pub/nmr/mirror.bruker.de.

Many files on the FTP server have names like: xyz.tar.gz. A file 
with a name like this: 

• is a tar-file, which probably contains a software package
• has been compressed with the command gzip
• must be uncompressed with: gunzip xyz.tar.gz
• must then be unpacked with: tar xvf xyz.tar

If gunzip does not exist on your computer, then get the gzip 
package from the FTP server as described below.
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examples

1. get the gzip software package for SGI

a) ftp ftp.bruker.de
Name: ftp
Password: -> enter your own full Email address
ftp> cd /pub/nmr/binaries.indy
ftp> bin
ftp> mget gzip* (answer each question with y)
ftp> bye

b) install the gzip package according to the readme file.

2. get all patches for XWIN-NMR 3.0 

a) ftp ftp.bruker.de
Name: ftp
Password: -> enter your own full Email address
ftp> cd /pub/nmr/xwinnmr/patches/xwinnmr3.0/sgi
ftp> bin
ftp> ls
ftp> get xw30pX.sgi.tar.gz

(X is a number greater than 0, the so called patchlevel)
ftp> get xw30pX.sgi.readme.txt
ftp> bye

b) install the patches according to the file 
xw30pX.sgi.readme.txt. 

You can also get these files from the directory:
/pub/nmr/mirror.bruker.de 

on the American FTP server. Usually, it is more efficient to use 
the server nearest to you.
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How to send a data set to Bruker 

directly from XWIN-NMR

The XWIN-NMR command smail provides a very easy way 
send data by Email: 

1. start xwinnmr 
2. go to the data set you want to send (e.g. with search)
3. type smail 
4. enter the Email address in the field Mail to, e.g.:

nmr-software-support@bruker.de
5. click on the field Output data, enter the data mode 
6. optionally fill out the fields message, subject and CC 1

7. click on send

Requirements: 

1. you run XWIN-NMR 1.3 or newer 2

2. Zmail (MediaMail) or Mutt is installed 3

3. you want to send a 1D data set

If you run an older version of XWIN-NMR or want to send 2D 
data, pack your data into a tar-file and do one of the following:

• put the tar-file on the FTP server
• convert the tar-file to ascii and send it by Email. 

This is described on the next page. 

1.In the field CC you can enter further destination Email addresses. 
2.In XWIN-NMR 1.3, ICONNMR must be installed. In XWIN-NMR 2.0 smail is independent of ICONNMR. 
3.Zmail is included in IRIX <= 6.2 but not in IRIX >= 6.3, Mutt is available on the SGI web page. 
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from a UNIX shell

Suppose you want to send to Bruker the NMR dataset:

/u/data/guest/nmr/exa 

Perform the following steps: 

1. cd /u/data/guest/nmr
2. tar cvf exa.tar exa

-> this creates the binary tar-file exa.tar
3. gzip exa.tar 1

-> this creates the compressed binary tar-file exa.tar.gz

There are different ways to send the file exa.tar.gz to Bruker, 
depending on your Internet/Email possibilities. 

1. if you have direct Internet access: 

type ftp ftp.bruker.de 
Name: ftp
Password: -> enter your own full Email address
ftp> cd /incoming
ftp> bin
ftp> put exa.tar.gz
ftp> bye

2. if you have Email it depends on your Email program:
a) if it supports binary attachments, e.g. Zmail2: 

-> send an Email and attach the binary file exa.tar.gz
b) if it doe not support binary attachments: e.g. elm: 

• uuencode exa.tar.gz exa.tar.gz > exa.asc3

• send an Email and include the ascii file exa.asc

1.If you do not have gzip, get it from the FTP server or use compress (this creates a file exa.tar.Z)
2.MediaMail is ’s version of the graphical Mail interface Zmail
3.The second argument is the name of the binary file which is created when the ascii file is decoded with
uudecode exa.asc. This can be the same as the name of the input file or any other name. 
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spectrometer internal network
a network with 2 hosts

All SGI workstations connected to a spectrometer are equipped 
with 2 ethernet interfaces and support an: 

• external network: interface ec0
• internal network: interface ec1(O2) or ec2 (indy)

If the SGI is connected to both the external and the internal net-
work, it has 2 hostnames and 2 IP addresses: 

• for the external laboratory network the SGI has an IP 
address corresponding to this network, e.g. 165.52.112.97 
and can have any hostname, e.g. host_a.

• for the internal spectrometer network the SGI has a fixed 
IP address: 149.236.99.1 a fixed hostname ASP_ST2

The only other host in the internal network is the CCU which 
has the fixed IP address 149.236.99.99 and hostname spect.

The files /etc/hosts on these 2 hosts will look like this: 

on the SGI on the CCU

127.0.0.1 localhost 127.0.0.1 localhost

149.236.99.1 ASP_ST2 149.236.99.1 ASP_ST2

149.236.99.99 spect 149.236.99.99 spect

165.52.112.97 host_a

 
NEVER change or delete these 3 lines
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The hostname of the CCU is always spect: you can log in on 
the CCU by typing telnet spect

You can, however, define an alias name for the CCU:
edit the file /etc/hosts on the SGI, append the alias e.g.:

149.236.99.99 spect dmx300

Now you can type telnet dmx300 to log in on the CCU. 

When you configure the spectrometer in XWIN-NMR with cf, 
you can now enter spect or dmx300 as instrument name. 

Important: the alias name for the CCU must be different from 
the hostname of the SGI workstation or any other host in the 
external network! 

If you have SGI-CCU communication problems, e.g. telnet 
spect does not work, do the following: 

1. open a UNIX shell 
2. type su - root to become superuser
3. type reviveccu

-> follow the instructions

If reviveccu does not solve the problem re-install the 
Diskless package from the XWIN-NMR CD.
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Bruker addresses
Germany

Bruker Analytik GmbH
Silberstreifen
D-76287 Rheinstetten
Tel: (++49) (721) 51 61 0
Fax: (++49) (721) 51 71 01

Bruker Software Department
Silberstreifen
D-76287 Rheinstetten
Tel: (++49) (721) 5161 440
Fax: (++49) (721) 5161 480

http://www.bruker.de

ftp server: ftp.bruker.de

Email: ut@bruker.de (sales)
       mbu@bruker.de (service)
       applik@bruker.de (application)
       nmr-software-support@bruker.de (software)
       license@bruker.de (licenses)

USA

Bruker Instruments Inc.
44 Manning Road
Billerica, MA. 01821-3991

Tel: (++1)(978) 667 9580 195 (center)
     (++1)(978) 667 9580 444 (application)
Fax: (++1)(978) 667 6168 (center)
     (++1)(978) 667 2955 (application)

http://www.bruker.com
http://www.bruker.com/nmr/center/centerform.html

ftp server: ftp.bruker.com

Email: applab@bruker.com
       center@bruker.com
       software@bruker.com

Switzerland

Bruker AG
Industriestraße 26
CH-8117 Fällanden

Tel: (++41)(1) 8 25 91 11
Fax: (++41)(1) 8 25 96 96

ftp server: ftp.spectrospin.ch

http://www.bruker.de
ftp://ftp.bruker.de
http://www.bruker.com
http://www.bruker.com/nmr/center/centerform.html
ftp://ftp.bruker.com
ftp://ftp.spectrospin.ch
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E-Mail: epweb@bruker.ch

                all_ap@bruker.ch

France

Bruker SA
34, rue de l’industrie
F-67166 Wissembourg/Cedex

Tel: (++33)(3) 88 73 68 00
Fax: (++33)(3) 88 73 68 79

E-Mail: support-rmn@bruker.fr (customer support)

England

Bruker UK LTD.
Banner lane
Coventry CV4 9GH
Tel: (++44)(2476) 855200
Fax: (++44)(2476) 465317

Email:service@bruker.co.uk
      apps@bruker.co.uk

Our webpage

http://www.bruker.de/analytic/nmr-dep/about/offices/contact.htm

provides contact adresses of our facilities and offices worldwide

http://www.bruker.de/analytic/nmr-dep/about/offices/contact.htm
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